您的位置:首页 > 大数据 > 人工智能

poj3735 Training little cats(矩阵快速幂)

2014-08-04 15:02 323 查看
Training little cats

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9872 Accepted: 2360
Description

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the
cats to do his exercises. Facer's great exercise for cats contains three different moves:

g i : Let the ith cat take a peanut.

e i : Let the ith cat eat all peanuts it have.

s i j : Let the ith cat and jth cat exchange their peanuts.

All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 

You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers n, m and k are given firstly, where n is the number of cats and k is the length of the move
sequence. The following k lines describe the sequence.

(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input
3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output
2 0 1


注意细节!
#include<stdio.h>
#include<string.h>
long long n,m;
struct ss
{
long long x[104][104];
};
ss s,t;
ss mul(ss a,ss b)
{
int i,j,u;
memset(t.x,0,sizeof(t.x));
for(i=0; i<=n; i++)
for(j=0; j<=n; j++)
if(a.x[i][j])
for(u=0; u<=n; u++)
t.x[i][u]+=a.x[i][j]*b.x[j][u];
return t;
}
/*
ss s;
ss mul(ss a,ss b)
{
ss t;//写成这样会超时,而memset耗时不多
int i,j,u;
for(i=0; i<=n; i++)
for(j=0; j<=n; j++)
if(a.x[i][j])
for(u=0; u<=n; u++)
t.x[i][u]+=a.x[i][j]*b.x[j][u];
return t;
}
*/
ss pow()
{
if(m==1) return s;
ss e;
memset(e.x,0,sizeof(e.x));
for(int i=0; i<=n; i++)
e.x[i][i]=1;
if(m==0) return e;
while(m)
{
if(m&1) e=mul(e,s);
m>>=1;
s=mul(s,s);
}
return e;
}
int main()
{
long long k,a,b;
int i;
char w[2];
while(scanf("%lld%lld%lld",&n,&m,&k),n|m|k)
{
memset(s.x,0,sizeof(s.x));
for(i=0; i<=n; i++)
s.x[i][i]=1;
while(k--)
{
scanf("%s",w);
if(w[0]=='g')
{
scanf("%lld",&a);
s.x[0][a]++;
}
else if(w[0]=='e')
{
scanf("%lld",&a);
for(i=0; i<=n; i++)
s.x[i][a]=0;
}
else
{
scanf("%lld%lld",&a,&b);
for(i=0; i<=n; i++)
{
long long r=s.x[i][a];
s.x[i][a]=s.x[i][b];
s.x[i][b]=r;
}
}
}
ss ans=pow();
for(i=1; i<n; i++)
printf("%lld ",ans.x[0][i]);
printf("%lld\n",ans.x[0][i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: