您的位置:首页 > 其它

动态规划—杭电ACM Bone Collector(01背包问题)

2014-08-02 10:13 465 查看
                                             
Bone Collector
[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?
[align=left] [/align]
[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 
[align=left]Sample Output[/align]

14

 

这个题也是经典的01背包问题之一,和前面的01背包问题相似就不再详细的注释了

AC代码:

#include<stdio.h>

#include<stdlib.h>

#include<string.h>

int v[1100],w[1100],f[2000];

int max(int a,int b)

{

    if(a>=b)

    return a;

    else

    return b;

}

int dp(int n,int m)

{

    int i,j;

    memset(v,0,sizeof(v));

    memset(w,0,sizeof(w));

    memset(f,0,sizeof(f));

   

    for(i=1;i<=n;i++)

    scanf("%d",&v[i]);

    for(i=1;i<=n;i++)

    scanf("%d",&w[i]);

   

    for(i=1;i<=n;i++)     //01背包问题的核心部分

    {

      for(j=m;j>=w[i];j--)

      {

      f[j]=max(f[j],f[j-w[i]]+v[i]);

      }

    }

    return f[m];

}

int main()

{

    int n,m,t;

    scanf("%d",&t);

    while(t--)

    {

    scanf("%d%d",&n,&m);

    printf("%d\n",dp(n,m));

    }

    return 0;

}

解题体会:我只想说我终于学会01背包问题了
解题时间:2014年8月2日(7夕情人节)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: