您的位置:首页 > 其它

HDU 2199 Can you solve this equation?(二分)

2014-07-31 15:57 267 查看
Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4


Sample Output

1.6152
No solution!


题目大意:

输入Y求1到100内满足方程 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y的解,结果保留四位小数,如果没有解,则输出No
solution!。

解题思路:

利用二分法,在1到100之间不断寻找x的值,直到x的值满足条件为止。

代码如下:

#include<stdio.h>
#include <math.h>
double sum(double x)
{
return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
int T;
double Y,low,high,mid;
scanf("%d",&T);
while(T--)
{
scanf("%lf",&Y);
if(sum(0)>Y||sum(100)<Y)
{
printf("No solution!\n");
continue;
}
low=0.0;
high=100.0;
mid=(low+high)/2;
while(fabs(sum(mid)-Y)>1e-5)
{
if(sum(mid)>Y)
high=mid-1;
else
low=mid+1;
mid=(low+high)/2;
}
printf("%.4lf\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: