您的位置:首页 > 其它

HDU 2199 Can you solve this equation(二分查找)

2014-07-21 20:46 302 查看


Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8158 Accepted Submission(s): 3759



Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4


Sample Output

1.6152
No solution!


#include<iostream>

#include<stdio.h>

#include<cmath>

using namespace std;

double y,root;

int main()

{

double bs(double,double);

double f(double);

int t,i,j;

scanf("%d",&t);

while(t--)

{

//scanf("%llf",&y);

cin>>y;//不能用c语言的格式输入double型数据,不信你可以立即输出y进行检验

double r=807020306;

if(y<6||y>r){printf("No solution!\n");}

else{root=bs(0,100);printf("%.4lf\n",root);}

}

return 0;

}

double f(double x)

{

return 8*x*x*x*x+ 7*x*x*x + 2*x*x + 3*x + 6-y;

}

//begin和end是解所在的区间范围

double bs(double begin,double end)

{

double mid;

while(fabs(end-begin)>1e-9)

{

mid=(begin+end)/2;

if(f(mid)>0){end=mid;}

else{begin=mid;}

}

return mid;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: