您的位置:首页 > 其它

uva101(The Blocks Problem)-线性表+模拟

2014-07-30 17:55 288 查看






  The Blocks Problem 

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm
performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of
commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks
on the table (numbered from 0 to n-1) with block bi adjacent
to block bi+1 for all 

 as
shown in the diagram below:
 

Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:
move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block ato their initial positions.

pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions
prior to the pile taking place. The blocks stacked above block a retain their order when moved.

pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain
their original order when moved.

quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration
of blocks.

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the
block world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.
You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i ( 

 where n is
the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other
block numbers by a space. Don't put any trailing spaces on a line.
There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit


Sample Output 

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

#include<stdio.h>
#include<string.h>
#define MAX 10
typedef struct{
int data[200];
int top;
}stack;
stack myStack[200];
int location[200];
void init(int n){
int i;
for(i=0;i<n;i++){
myStack[i].top=0;
myStack[i].data[0]=i;
location[i]=i;
myStack[i].top=1;
}
}
bool can_operate(int a,int b){
if(a==b||location[a]==location[b])
return false;
else
return true;
}
void conduct1(int a,int b){
int loc1=location[a];
int loc2=location[b];
int temp;
if(myStack[loc1].top!=0&&myStack[loc2].top!=0){
while(myStack[loc1].data[myStack[loc1].top-1]!=a){
temp=myStack[loc1].data[myStack[loc1].top-1];
location[temp]=temp;
myStack[temp].data[myStack[temp].top]=temp;
myStack[temp].top++;
myStack[loc1].top--;
}
while(myStack[loc2].data[myStack[loc2].top-1]!=b){
temp=myStac
4000
k[loc2].data[myStack[loc2].top-1];
location[temp]=temp;
myStack[temp].data[myStack[temp].top]=temp;
myStack[temp].top++;
myStack[loc2].top--;
}
location[a]=loc2;
myStack[loc1].top--;
myStack[loc2].data[myStack[loc2].top]=a;
myStack[loc2].top++;
}
}
void conduct2(int a,int b){
int loc1=location[a];
int loc2=location[b];
int temp;
if(myStack[loc1].top!=0){
while(myStack[loc1].data[myStack[loc1].top-1]!=a){
temp=myStack[loc1].data[myStack[loc1].top-1];
location[temp]=temp;
myStack[temp].data[myStack[temp].top]=temp;
myStack[temp].top++;
myStack[loc1].top--;
}
location[a]=loc2;
myStack[loc1].top--;
myStack[loc2].data[myStack[loc2].top]=a;
myStack[loc2].top++;
}
}
void conduct3(int a,int b){
int loc1=location[a];
int loc2=location[b];
int temp;
if(myStack[loc1].top!=0&&myStack[loc2].top!=0){
while(myStack[loc2].data[myStack[loc2].top-1]!=b){
temp=myStack[loc2].data[myStack[loc2].top-1];
location[temp]=temp;
myStack[temp].data[myStack[temp].top]=temp;
myStack[temp].top++;
myStack[loc2].top--;
}
int marktop;
marktop=myStack[loc1].top;
while(myStack[loc1].data[marktop-1]!=a){
marktop--;
}
int t=marktop;
while(marktop-1!=myStack[loc1].top){
temp=myStack[loc1].data[marktop-1];
location[temp]=loc2;
myStack[loc2].data[myStack[loc2].top]=temp;
myStack[loc2].top++;
marktop++;
}
myStack[loc1].top=t-1;
}
}
void conduct4(int a,int b){
int loc1=location[a];
int loc2=location[b];
int temp;
if(myStack[loc1].top!=0&&myStack[loc2].top!=0){
int marktop;
marktop=myStack[loc1].top;
while(myStack[loc1].data[marktop-1]!=a){
marktop--;
}
int t=marktop;
while(marktop-1!=myStack[loc1].top){
temp=myStack[loc1].data[marktop-1];
location[temp]=loc2;
myStack[loc2].data[myStack[loc2].top]=temp;
myStack[loc2].top++;
marktop++;
}
myStack[loc1].top=t-1;
}
}
void print(int n){
int i,j;
for(i=0;i<n;i++){
printf("%d:",i);
for(j=0;j<myStack[i].top;j++){
printf(" %d",myStack[i].data[j]);
}
printf("\n");
}
}
int main(){
char s1[MAX],s2[MAX];
int number1,number2;
int n;
scanf("%d",&n);
init(n);
while(scanf("%s",s1)!=EOF){
if(strcmp(s1,"quit")==0){
print(n);
break;
}
scanf("%d%s%d",&number1,s2,&number2);
int i;
if(can_operate(number1,number2)){
if(strcmp(s1,"move")==0){
if(strcmp(s2,"onto")==0){
conduct1(number1,number2);
}
else if(strcmp(s2,"over")==0){
conduct2(number1,number2);
}
}
else if(strcmp(s1,"pile")==0){
if(strcmp(s2,"onto")==0){
conduct3(number1,number2);
}
else if(strcmp(s2,"over")==0){
conduct4(number1,number2);
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva