您的位置:首页 > 其它

HDU 2199 Can you solve this equation(二分)

2014-07-29 12:28 337 查看

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8292 Accepted Submission(s): 3830


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input
2
100
-4




Sample Output
1.6152
No solution!


水题一道~~~不过也是很经典的二分解线性方程的题目。

题意:给个方程 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 ==Y,题目给出Y,在区间[0,100]内求解。

分析:求导可知该函数在[0,100]上是单增的,有单调性,故可用二分求解。 完全是模板题~~~

AC代码:

#include<cmath>
#include<cstdio>
#define eps 1e-8

double fun(double x)
{
    return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
}

int main()
{
    double y,a,b,m,d;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf",&y);
        if(y<fun(0) || y>fun(100))
        {
            printf("No solution!\n");
            continue;
        }
        a=0.0;
        b=100.0;
        while(b-a>eps)
        {
            m=b+(a-b)/2;
            if(fun(m)<y)  a=m;
            else   b=m;
        }
        printf("%.4f\n",a);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: