您的位置:首页 > 大数据 > 人工智能

2014 Multi-University Training Contest 2---ZCC Loves Codefires

2014-07-24 16:29 513 查看

ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 0 Accepted Submission(s): 0



Problem Description
Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".
   It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.
   But why?
   Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve  certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the  best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures.
   After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.
   What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the  problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time.
   Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the  minimal score he will lose.(that is, the sum of Ki*Ti).




Input
The first line contains an integer N(1≤N≤10^5), the number of problem in the round.
   The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.
   The last line contains N integers Ki(1≤Ki≤10^4), as was described.




Output
One integer L, the minimal score he will lose.




Sample Input
3
10 10 20
1 2 3




Sample Output
150

HintMemset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second.
L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150.


#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
using namespace std;
//#include<windows.h>
//#include<conio.h>
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
#define mem(a,b) memset(a,b,sizeof(a))
#define malloc(sb) (sb *)malloc(sizeof(sb))
//int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
struct wo 
{
    int x,y;
    double z;
};
int cmp(wo  mm,wo  nn)
{
    return mm.z<nn.z;
}
wo  mm[100001];
int main()
{
    long long int n,i,j;
    long long int  num=0,sum=0;
    scanf("%lld",&n);
    memset(mm,0,sizeof(mm));
    for(i=0; i<n; i++) scanf("%d",&mm[i].x);
    //   printf("%d\n",a[i].x)'
    for(i=0; i<n; i++)
    {
        scanf("%d",&mm[i].y);
       mm[i].z=mm[i].x*1.0/mm[i].y;
    }
    //  printf("%d\n",a[i].z);
    sort(mm,mm+n,cmp);
    for(i=0; i<n; i++)
    {
        num+=mm[i].x;
   //     printf("%d\n",num);
        sum+=num*mm[i].y;
    }
    printf("%I64d\n",sum);
    return 0;
}
本来是大二学长的比赛,给我们大一的留了一个账号,这题,光看懂题意就折腾了半天

,后来逐渐清晰 了思路,错了好多次,终于抓住了细节,改为long long ,

可能是题目数据给的有点大。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐