您的位置:首页 > 移动开发

UVALive 6084 Happy Camper(数学题)

2014-07-20 21:53 429 查看
题目链接:https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=4095

----------------------------------------------------------------------------------------------------------------------------------------------------------

欢迎光临天资小屋






http://user.qzone.qq.com/593830943/main


----------------------------------------------------------------------------------------------------------------------------------------------------------


As Happy Camper Harry pulls into his favorite campground with his family, he notices the sign:

'Campground occupancy is limited to 10 days within any consecutive 20-day period.' Harry is just

starting a 28-day vacation. What is the maximum number of days he can occupy a campsite during

his vacation?

We state the problem in more general terms. Suppose that 1 < L < P < V are integers. Camp-

ground occupancy is limited to L days within any consecutive P-day period. Happy Camper Harry

is just starting a V -day vacation. What is the maximum number of days he can occupy a campsite

during his vacation?

Input

The input will contain data for a number of test cases. For each test case, there will be one line of data,

containing values of L, P and V , in that order. All input integers can be represented by signed 32-bit

integers. End of data will be signaled by a line containing three zeros, which will not be processed.

Output

There will be one line of output for each test case. It will display the case number and the number of

days Happy Camper Harry can occupy a campsite during his vacation. The format is illustrated by

the sample output.

Sample Input

5 8 20

5 8 17

0 0 0

Sample Output

Case 1: 14

Case 2: 11

代码如下:

#include<stdio.h>
#define ll long long
int main()
{
	ll l,p,v;
	ll ans,temp;
	int cas=1;
	while(scanf("%lld %lld %lld",&l,&p,&v)!=EOF)
	{
		if(l==0 && p==0 && v==0)
			break;
		temp=v%p;
		if(temp>=l)
		{
			temp = l;
		}
		ans=(v/p)*l+temp;
		
		printf("Case %d: ",cas++);
		printf("%lld\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: