您的位置:首页 > 产品设计 > UI/UE

UVA133 The Dole Queue

2014-07-20 20:40 344 查看
Description
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen
as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting
m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until
no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the
end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive
pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output


4


8,


9


5,


3


1,


2


6,


10,


7

where

represents a space.

题目意思就是n个人围一圈,然后两个官员,一个从1开始往大的方向数,数到第k个就选中。。一个是从n开始往小的方向数,数到第m个选中,数的时候被选中的要跳过。

注意是两人同时数完一次,然后这两人才被标记,并且第一个官员先输出,第二个官员后输出,如果两人选中同一个,则只输出一个。直到全选中完。。

用数组模拟即可;

AC代码如下;

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

int n,k,m;
int count;
int num1,num2;
int p[30] = {0};
int judge(int num) {
for (int l = 0 ; l < k ;) {

if(p[num++] == 0)
l++;
if (num > n)
num = 1;
}
return num - 1;
}

int judge2(int num) {
for (int l = 0; l < m;) {

if(p[num--] == 0)
l++;
if(num < 1)
num = n;
}
return num + 1;

}

int main () {
while (cin >> n >> k >> m) {
if (n == 1) {

printf("  1\n");
continue;

}
count = 0;
if(n + k + m == 0)
break;
num1 = 0;
num2 = n + 1;
while (count < n) {
num1 = judge (num1 + 1);
num2 = judge2 (num2 - 1);
if (num1 == 0)
printf("%3d",n);
else
printf("%3d",num1);
count++;
if((num2 != num1) && !(num1 == 0 && num2 == n) && !(num1 == 1&&num2 == n + 1)) {
if (num2 == n + 1)
printf("%3d",1);
else
printf("%3d",num2);
count++;
}
if (count != n)
printf(",");
else
printf("\n");
if(num1 == 0)
p
= 1;
if(num2 == n + 1)
p[1] = 1;
p[num1] = 1;
p[num2] = 1;
}
memset(p , 0 ,sizeof(p));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: