您的位置:首页 > 其它

20140714 「初等数论 - 中国剩余定理」 POJ 1006 Biorhythms

2014-07-14 18:56 681 查看



Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board

Home Page

F.A.Qs

Statistical Charts
Problems

Submit Problem

Online Status

Prob.ID:
Register

Update your info

Authors ranklist

Current Contest

Past Contests

Scheduled Contests

Award Contest
wilson1068 Log
Out

Mail:0(0)

Login Log Archive
Language:
Default简体中文

Biorhythms

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 111895Accepted: 34861
Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one
peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will
be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine
the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give
the number of days to the next occurrence of a triple peak.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles
peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by
a line in which p = e = i = d = -1.
Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1.
Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source

East Central North America 1999
[Submit] [Go Back]
[Status] [Discuss]


Home
Page

Go Back

To
top

All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di

Any problem, Please Contact Administrator

数论:中国剩余定理 模板一份。

题解嘛,有空再补。。。(其实就是模板题。)

用现代数学的语言来说明的话,中国剩余定理给出了以下的一元线性同余方程组:



有解的判定条件,并用构造法给出了在有解情况下解的具体形式。

中国剩余定理说明:假设整数m1, m2,
... , mn两两互质,则对任意的整数:a1, a2,
... , an,方程组

有解,并且通解可以用如下方式构造得到:



是整数m1, m2,
... , mn的乘积,并设

是除了mi以外的n -
1个整数的乘积。






的数论倒数:


方程组

的通解形式为:

在模

的意义下,方程组

只有一个解:


中国剩余定理 Wiki 百科:

http://zh.wikipedia.org/wiki/%E5%AD%99%E5%AD%90%E5%AE%9A%E7%90%86

#include <stdio.h>
int main(){
int p, e, i, d, n=21252, no=0;
while( ~scanf("%d%d%d%d", &p,&e,&i,&d) ){
if( p<0 )	break;
int ans = (5544*p + 14421*e + 1288*i+n-1-d)%n+1;
printf("Case %d: the next triple peak occurs in %d days.\n", ++no, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: