您的位置:首页 > 其它

UVA 12709 Falling Ants(简单的比较大小)

2014-07-02 10:06 204 查看




Input

The input file contains at most 500 test cases. The description of each test case is given below:

First line of each test case contains an integer T (T ≤ 100) which denotes the total number of ants

to consider. Each of the next T lines contains three integers which denote the value of L, W and H

(1 ≤ L,W,H ≤ 50) of an ant respectively.

Input is terminated by a line containing a single zero.

Output

For each set of input produce one line of output. This line contains the volume of the ant that has the

highest downward acceleration. If there is a tie report the ant with the highest volume.

Sample Input

3

3 4 5

12 1 5

20 10 4

3

3 4 5

20 30 5

1 2 4

0

Sample Output

60

3000

AC代码:

#include <stdio.h>
//author:XXYY
int main(){
int T,l,w,h,maxh,t,max;
while(~scanf("%d",&T),T){
t=1;
maxh=max=0;
while(T--){
scanf("%d%d%d",&l,&w,&h);
if(t){
maxh=h;
max=l*w*h;
t=0;
}
else{
if(maxh<h){
maxh=h;
max=l*w*h;
}
else if(maxh==h)
if(l*w*h>max)
max=l*w*h;
}
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: