您的位置:首页 > 其它

POJ 1979 Red and Black (DFS的简单应用)

2014-07-03 15:53 423 查看
Red and Black

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 21765Accepted: 11671
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13


AC代码:
#include <stdio.h>
#include <string.h>
char mp[25][25];
int vis[25][25],sum;

void dfs(int x,int y){
if(mp[x][y]=='#'||vis[x][y]==1)
return ;
sum++;
vis[x][y]=1;
dfs(x+1,y);
dfs(x-1,y);
dfs(x,y+1);
dfs(x,y-1);
}

int main(){

int w,h,i,j,x,y;
while(~scanf("%d%d",&w,&h),(w+h)){
getchar();
sum=0;
memset(vis,0,sizeof(vis));
memset(mp,'#',sizeof(mp));
for(i=1;i<=h;i++){
for(j=1;j<=w;j++){
scanf("%c",&mp[i][j]);
if(mp[i][j]=='@'){
x=i;
y=j;
}
}
getchar();
}
dfs(x,y);
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: