您的位置:首页 > 其它

poj 3617 Best Cow Line(取字典序最小的一种排序)

2014-06-26 10:14 127 查看
Best Cow Line

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9188Accepted: 2793
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase
ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's
finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input
6
A
C
D
B
C
B

Sample Output
ABCBCD

题意:给你一系列字母, 要你取出字典序最小的字符串,每次只能从最上面或者最下面进行取
AC代码:

#include <stdio.h>
//author:YangSir
char a[2005];
int main(){
int n,i,num,flag,l,r,ll,rr;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%*c%c",&a[i]);
l=0;r=n-1;num=0;
while(l<=r){
if(a[l]<a[r])
printf("%c",a[l++]);
else if(a[l]>a[r])
printf("%c",a[r--]);
else{
ll=l;
rr=r;
while(a[ll]==a[rr]){
ll++;
rr--;
}
if(a[ll]<a[rr])
printf("%c",a[l++]);
else if(a[ll]>a[rr])
printf("%c",a[r--]);
}
num++;
if(num%80==0)
printf("\n");
}
if(num%80)
printf("\n");
return 0;
}


#include <stdio.h>
//author:YangSir
char a[2005];
int main(){
int n,i,num,flag,l,r;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%*c%c",&a[i]);
l=0;r=n-1;num=0;
while(l<=r){
flag=0;
for(i=0;i<=r-l;i++){
if(a[i+l]<a[r-i]){
flag=0;break;
}
else if(a[i+l]>a[r-i]){
flag=1;break;
}
}
if(flag)
printf("%c",a[r--]);
else
printf("%c",a[l++]);
num++;
if(num%80==0)
printf("\n");
}
if(num%80)
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: