您的位置:首页 > 其它

POj 3617 Best Cow Line

2013-07-28 13:47 288 查看
Best Cow Line

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6252Accepted: 2010
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

贪心简单题,给一个字符串,每次可以从它的开头或末尾取一个字母,求使构成的新字符串字典序最小。

每次只要比较开头和结尾的两个字母取小的一个即可,若两字母相同则比较第二位

#include<stdio.h>
#include<string.h>

#define LEFT 1
#define RIGHT 2

int n;
char s[2050],ans[2050];

int Position(int left,int right)
{
if(s[left]<s[right])
return LEFT;
else if(s[left]>s[right])
return RIGHT;
else if(left+1<right-1)
return Position(left+1,right-1);
else
return LEFT;
}

int main()
{
int i,left,right,t;

while(scanf("%d",&n)==1)
{
getchar();

for(i=0;i<n;i++)
{
s[i]=getchar();
getchar();
}
s
='\0';

left=t=0;
right=n-1;

while(left<right)
{
switch(Position(left,right))
{
case LEFT:ans[t++]=s[left++];break;
case RIGHT:ans[t++]=s[right--];break;
}
}
ans[t]=s[left];

for(i=0;i<=t;i++)
{
putchar(ans[i]);
if(i%80==79)
putchar('\n');
}
printf("\n");
}

return 0;
}


[C++]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: