您的位置:首页 > 其它

POJ 3140 Contestants Division(简单的树形dp)

2014-06-21 23:27 344 查看
题意很简单,也比较好读懂。

思路:求出总和sum,然后dfs求出每一个节点总和ans与sum-2*ans的绝对值的最小值。

一定要注意数据范围啊。

Contestants Division

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7942 Accepted: 2267
Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee
can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between
the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the
committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university
does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input
7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output
Case 1: 1

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-9
///#define M 1000100
///#define LL __int64
#define LL long long
#define INF 0x7ffffff
#define PI 3.1415926535898

using namespace std;

const int maxn = 120000;

struct node
{
int to;
int next;
} f[1001000];

int t;
int n, m;
int head[maxn];
LL sum;
LL num[maxn];
LL Min;

void init()
{
t = 0;
sum = 0;
memset(head, -1, sizeof(head));
}

void add(int x, int y)
{
f[t].to = y;
f[t].next = head[x];
head[x] = t++;

f[t].to = x;
f[t].next = head[y];
head[y] = t++;
}
LL _abs(LL x)
{
if(x < 0)
return -x;
return x;
}

LL dfs_sum(int x, int fa)
{
LL ans = num[x];
for(int i = head[x]; i != -1; i = f[i].next)
{
int v = f[i].to;
if(v == fa)
continue;
ans += dfs_sum(v, x);
}
Min = min(Min, _abs(sum-2*ans));
return ans;
}

int main()
{
int Case = 1;
while(cin >>n>>m)
{
if(!n && !m)
break;
init();
for(int i = 1; i <= n; i++)
{
scanf("%lld", &num[i]);
sum += num[i];
}
int x, y;
for(int i = 1; i <= m; i++)
{
scanf("%d %d",&x, &y);
add(x, y);
}
Min = sum;
dfs_sum(1, -1);
cout<<"Case "<<Case++<<": ";
cout<<Min<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: