您的位置:首页 > 其它

HDU 4324 Triangle LOVE (拓扑排序)

2014-06-06 16:33 316 查看


Triangle LOVE

Problem Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.



Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).



Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.



Sample Input

2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110




Sample Output

Case #1: Yes
Case #2: No




Author

BJTU



Source

2012 Multi-University Training Contest 3



题目大意:

T组测试数据,每组数据一个n表示n个人,接下n*n的矩阵表示这些人之间的关系,输入一定满足若A不喜欢B则B一定喜欢A,且不会出现A和B相互喜欢的情况,问你这些人中是否存在三角恋。

解题思路:

拓扑排序思想很简单,就是找入度为0的点,放入队列,用队列来实现。

拓扑排序后判断是否有环存在,有环必然存在是三角恋。

证明:

假设存在一个n元环

首先,n必然>1,因为1元能算环吗,什么,自己喜欢自己?那不行,我们都很谦虚的!

然后,n=2时不可能,环的大小不会为2,有人问为什么?傻逼啊,因为题目自己说不会出现A和B相互喜欢的情况。

其次,n=3时,不要判断,3个人不就刚好三角恋了吗。


因此,n>3,证明 必然存在3元环就可以了。

下 证:

因为假设有环上三个相邻的点a-> b-> c,那么如果c->a间有边,就已经形成了一个三元环,如果c->a没边,那么a->c肯定有边,除去b,这样就形成了一个n-1元环,依次递推下去,最差递推到n=4时,得证。什么,不会递推下去?和我有关系吗?

解题代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <string>
using namespace std;

const int maxn=2100;
int n,degree[maxn];
vector <vector<int> > v;

void input(){
    v.clear();
    scanf("%d\n",&n);
    v.resize(n);
    for(int i=0;i<=n;i++) degree[i]=0;
    for(int i=0;i<n;i++){
        char st[maxn];
        scanf("%s",st);
        for(int j=0;j<n;j++){
            if(st[j]=='1'){
                v[i].push_back(j);
                degree[j]++;
            }
        }
    }
}

void solve(){
    int ans=0;
    queue <int> q;
    for(int i=0;i<n;i++){
        if(degree[i]==0) q.push(i);
    }
    while(!q.empty()){
        int s=q.front();
        q.pop();
        degree[s]--;
        ans++;
        for(int i=0;i<v[s].size();i++){
            int d=v[s][i];
            degree[d]--;
            if(degree[d]==0){
                q.push(d);
            }
        }
    }
    if(ans!=n) printf("Yes\n");
    else printf("No\n");
}

int main(){
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        input();
        printf("Case #%d: ",i);
        solve();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: