您的位置:首页 > 其它

HDU 4324-- Triangle LOVE【拓扑排序 && 邻接表实现】

2015-08-14 11:48 441 查看

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 3496 Accepted Submission(s): 1357



Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.



Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).


Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.



Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110




Sample Output
Case #1: Yes
Case #2: No




题目大意:

T组测试数据,每组数据一个n表示n个人,接下n*n的矩阵表示这些人之间的关系,输入一定满足若A不喜欢B则B一定喜欢A,且不会出现A和B相互喜欢的情况,问你这些人中是否存在三角恋。

解题思路:

拓扑排序后判断是否有环存在,有环必然存在是三角恋。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define maxn 2010
using namespace std;

char map[maxn];
int indu[maxn];
int head[maxn], cnt;
int n, k;

struct node {
    int u, v, next;
};

node edge[maxn * maxn];

void init(){
    cnt = 0;
    memset(head, -1, sizeof(head));
    memset(indu, 0, sizeof(indu));
}

void add(int u, int v){
    edge[cnt] = {u, v, head[u]};
    head[u] = cnt++;
}

void input(){
    scanf("%d", &n);
    for(int i = 0; i < n; ++i){
        scanf("%s", map);
        for(int j = 0; j < n; ++j)
            if(map[j] == '1'){
                add(i, j);
                indu[j]++;
            }
    }
}

void topsort(){
    printf("Case #%d: ", ++k);
    queue<int >q;
    int ans = 0;
    for(int i = 0; i < n; ++i){
        if(!indu[i]){
            q.push(i);
            ans++;
        }
    }
    while(!q.empty()){
        int u = q.front();
        q.pop();
        for(int i = head[u]; i != -1; i = edge[i].next){
            int v = edge[i].v;
            indu[v]--;
            if(!indu[v]){
                q.push(v);
                ans++;
            }
        }
    }
    if(n == ans)
        printf("No\n");
    else
        printf("Yes\n");
}

int main (){
    int T;
    scanf("%d", &T);
    k = 0;
    while(T--){
        init();
        input();
        topsort();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: