您的位置:首页 > 其它

POJ训练计划1426_Find The Multiple(BFS)

2014-06-04 14:34 435 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17011 Accepted: 6929 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

Source

Dhaka 2002

解题报告

坑人。。。其实m压根就没有100位那么大,虽然是特判的。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;
int n;
queue<long long >Q;
void bfs()
{
while(!Q.empty())
Q.pop();
Q.push(1);
while(!Q.empty())
{
long long next=Q.front();
Q.pop();
if(next%n==0)
{
cout<<next<<endl;
return ;
}
Q.push(next*10);
Q.push(next*10+1);
}
}

int main()
{
while(cin>>n,n)
{
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: