您的位置:首页 > 其它

最短路(floyd) Cow Hurdles

2014-04-26 00:52 393 查看

Cow Hurdles

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 113   Accepted Submission(s) : 59
[align=left]Problem Description[/align]

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows' practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1..N. A set ofM (1 ≤M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Pathi
travels from stationSi to station Ei and contains exactly one hurdle of heightHi (1 ≤Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task
i comprises two distinct numbers, Ai and Bi (1 ≤Ai ≤N; 1 ≤
Bi ≤ N), which connote that a cow has to travel from stationAi to stationBi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of
the tallest hurdle they jump over when traveling fromAi toBi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.

 

 

[align=left]Input[/align]

* Line 1: Three space-separated integers: N, M, and T

* Lines 2..M+1: Line i+1 contains three space-separated integers:Si ,Ei , and
Hi

* Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i:Ai andBi

 

[align=left]Output[/align]

* Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

 

[align=left]Sample Input[/align]

5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1

 

[align=left]Sample Output[/align]

4
8
-1

 

题目意思:

  牛回家,找出所有牛回家时最高的障碍物

 题目分析:

1)采用floyd 算法, 不过要改变控制条件:

    if(Edge[i][j]>max(Edge[i][k],Edge[k][j]))

                 Edge[i][j]=max(Edge[i][k],Edge[k][j]);

这句话的内涵是:如果Edge[i][k]  && Edge[k][j]都不为INF,找出其中最大的值,并与Edge[i][j]进行比较,找出较小值

2)floyd的变形比较特别,可以分析之:有多源多汇,所以采用floyd

#include<stdio.h>

#include<string.h>

#include<math.h>

#define maxn 305

#define INF 0x3f3f3f3f

int n,m,t;

int Edge[maxn][maxn];

int max(int a,int b)

{

    return a>b?a:b;

}

void floyd()

{

     for ( int k= 1; k<= n; k++ )   // n为节点个数

    {

        for ( int i= 1; i <=n; i++ )

         {

            for ( int j = 1; j <=n; j++ )

             {

             if(Edge[i][j]>max(Edge[i][k],Edge[k][j]))

                 Edge[i][j]=max(Edge[i][k],Edge[k][j]);

             }

        }

    }

}

int main()

{

    int i,u,v,w,a,b;

    while(scanf("%d%d%d",&n,&m,&t)!=EOF)

    {

        memset(Edge,0x3f,sizeof Edge);

        for(i=1;i<=n;i++)

            Edge[i][i]=0;

        while(m--)

        {

            scanf("%d%d%d",&u,&v,&w);

            Edge[u][v]=w;

        }

        floyd();

        while(t--)

        {

            scanf("%d%d",&a,&b);

            if(Edge[a][b]==INF)

            printf("-1\n");

            else

             printf("%d\n",Edge[a][b]);

        }

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  floyd