您的位置:首页 > 产品设计 > UI/UE

hdu 1423 Greatest Common Increasing Subsequence(LIS)

2014-04-22 17:49 344 查看

Greatest Common Increasing Subsequence

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3561 Accepted Submission(s): 1126

[/b]

[align=left]Problem Description[/align]

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

[align=left]Input[/align]

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

[align=left]Output[/align]

output print L - the length of the greatest common increasing subsequence of both sequences.

[align=left]Sample Input[/align]

1

5
1 4 2 5 -12
4
-12 1 2 4


[align=left]Sample Output[/align]

2


最长递增公共子序列,注意格式

#include"stdio.h"
#include"string.h"
#define N 505
int Max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int i,j,n,m,T;
int a
,b
;
int dp
;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(i=0;i<m;i++)
scanf("%d",&b[i]);
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
{
int max=0;   //记录数组a[i]前i个,b[j]前j个的最长递增公共子序列长度
for(j=0;j<m;j++)
{
if(a[i]>b[j])     //记录可用的最大dp[[j]
max=Max(max,dp[j]);
else if(a[i]==b[j])    //更新dp[j]的值
dp[j]=Max(max+1,dp[j]);
}
}
int max=0;
for(i=0;i<m;i++)
max=Max(max,dp[i]);
printf("%d\n",max);
if(T)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: