您的位置:首页 > 产品设计 > UI/UE

HDU 1423 Greatest Common Increasing Subsequence 最长公共递增序列

2015-03-13 21:43 423 查看

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4647 Accepted Submission(s): 1484


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
Output
output print L - the length of the greatest common increasing subsequence of both sequences.
Sample Input
1

5
1 4 2 5 -12
4
-12 1 2 4


Sample Output
2


#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 505
int a
,b
,dp
;

int main()
{
	int i,j,k,n,m,max,t;
	//freopen("text.txt","r",stdin);
	scanf("%d",&t); 
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		scanf("%d",&m);
		for(i=0;i<m;i++)
			scanf("%d",&b[i]);
		memset(dp,0,sizeof(dp));
		max=-1;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(a[i]==b[j])
				{
					dp[j]=1;
					for(k=0;k<j;k++)
					{
						if(b[k]<b[j]&&dp[j]<dp[k]+1)
							dp[j]=dp[k]+1;
					}
				}
				if(dp[j]>max)
					max=dp[j];
			}
		printf("%d\n",max);
		if(t!=0)
			printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐