您的位置:首页 > Web前端

NYOJ 248 BUYING FEED (贪心)

2014-04-11 08:18 274 查看

BUYING FEED

时间限制:3000 ms | 内存限制:65535 KB
难度:4
描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.
The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location
X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.

Amazingly, a given point on the X axis might have more than one store.
Farmer John starts at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can
stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit. What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John

knows there is a solution. Consider a sample where Farmer John needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:

0 1 2 3 4 5

---------------------------------

1 1 1 Available pounds of feed

1 2 2 Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels
from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.
When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow

There are multi test cases ending with EOF.

Each case starts with a line containing three space-separated integers: K, E, and N

Then N lines follow :every line contains three space-separated integers: Xi Fi Ci

输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
1
2 5 3                 
3 1 2
4 1 2
1 1 1


样例输出
7


题意:一条数轴上有n个商店,第i个商店在Xi的位置,最多可以卖Fi磅feed,每磅Ci元。一个人从起点0开始,终点为E,当他到达E点时,至少要买K磅feed,带着1磅feed每前进一个单位,就要额外花费1元。求最小花费是多少。

分析:这道题可以用贪心来做。先求出这个人在每个商店买1磅到达E点时的花费,把它作为这个商店的单价,那么我们在买时就不用考虑这个商店与E点的距离,只需要贪心选择单价小的即可。

#include<stdio.h>
#include<algorithm>
using namespace std;
struct store
{
    int pos; //商店位置
    int f; //最多卖的数量
    int c; //处理前的单价
    int s; //处理后的单价
}a[105];

bool comp(store a1, store a2)
{
    return a1.s < a2.s; //优先选择单价小的
}

int main()
{
    int k, L, n, i, j, sum, T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&k,&L,&n);
        for(i = 0; i < n; i++)
        {
            scanf("%d%d%d",&a[i].pos, &a[i].f, &a[i].c);
            a[i].s = L - a[i].pos + a[i].c;  //把这个商店到终点的距离和原来的单价一起作为新的单价
        }
        sort(a, a+n,comp);
        int sum = 0, cnt = 0;
        for(i = 0; i < n; i++)
        {
            if(cnt < k)
            {
                if(cnt + a[i].f <= k)
                {
                    sum += a[i].f * a[i].s;
                    cnt += a[i].f;
                    if(cnt == k)
                        break;
                }
                else
                {
                    sum += (k - cnt) * a[i].s;
                    break;
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: