您的位置:首页 > Web前端

NYOJ-248-BUYING FEED(第三届河南省程序设计大赛E题(贪心))

2017-04-23 19:44 330 查看

BUYING FEED

时间限制:3000 ms  |  内存限制:65535 KB
难度:4

描述
Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 <
X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.

Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores
along the way and buy any amount of feed up to the the store's limit.  What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John

knows there is a solution. Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:     

0   1   2  3   4   5    

---------------------------------         

1       1   1                Available pounds of feed         

1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit
of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入The first line of input contains a number c giving the number of cases that follow

There are multi test cases ending with EOF.

Each case starts with a line containing three space-separated integers: K, E, and N

Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed样例输入
12 5 3                 3 1 24 1 21 1 1

样例输出
7


题解:

题目大意:
FJ开车去买K份食物,如果他的车上有X份食物。每走一里就花费X元。 FJ的城市是一条线,总共E里路,有E+1个地方,标号0~E。 FJ从0开始走,到E结束(不能往回走),要买K份食物。 城里有N个商店,每个商店的位置是X_i(一个点上可能有多个商店),有F_i份食物,每份C_i元。 问到达E并买K份食物的最小花费

我的思路:

就是求出每个地点食物的总花费,即买食物的花费和把食物运到目的地的花费加到一起设置为这个地点的这个食物的权值,然后贪心。

下面附上代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct S
{
int x;
int f;
int c;
}a[105];
bool cmp(S a1, S a2)
{
return a1.c < a2.c;
}
int main()
{
int N;
while(~scanf("%d", &N))
{
int k, e, n;
while(~scanf("%d%d%d", &k, &e, &n))
{
int sum = 0;
for(int i = 0; i < n; i++)
{
scanf("%d%d%d", &a[i].x, &a[i].f, &a[i].c);
a[i].c += e - a[i].x;
}
sort(a, a+n, cmp);
for(int i = 0; i < n; i++)
{
if(a[i].f <= k)
{
k = k-a[i].f;
sum += a[i].f * a[i].c;
}
else
{
sum += k * a[i].c;
break;
}
}
printf("%d\n", sum);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息