您的位置:首页 > 其它

HDU 2689 Sort it

2014-04-05 16:25 274 查看
Problem Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.

For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3
1 2 3
4
4 3 2 1


Sample Output

0
6排序基本功,注意不能用选择排序
#include<stdio.h>
int a[1005];
int main()
{
int n,i,j,s,t;
while(scanf("%d",&n)!=EOF)
{
s=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<n;i++)//冒泡
for(j=i+1;j<n;j++)
if(a[i]>a[j])
{
s++;
t=a[i];
a[i]=a[j];
a[j]=t;
}
printf("%d\n",s);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: