您的位置:首页 > 大数据 > 人工智能

九度题目1436:Repair the Wall

2014-04-01 16:40 393 查看
原题链接:http://ac.jobdu.com/problem.php?pid=1436

题目描述:

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is

a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.

The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired
perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

输入:

The problem contains many test cases, please process to the end of file( EOF ).

Each test case contains two lines.

In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which

mentioned above.

In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

输出:

For each test case , print an integer which represents the minimal number of blocks are needed.

If Kitty could not repair the wall, just print "impossible" instead.

样例输入:

5 3

3 2 1

5 2

2 1

样例输出:

2

impossible

代码如下:

#include <stdio.h>
#include <stdlib.h>
#define MAXN 601

int cmp(const void *a,const void *b){
return *(int *)b-*(int *)a;
}

int main(int argc, char *argv[]) {
int n,l,num[MAXN];
while(scanf("%d%d",&l,&n)!=EOF){
int i;
for(i=0;i<n;i++){
scanf("%d",&num[i]);
}
qsort(num,n,sizeof(num[0]),cmp);
int max=0;
for(i=0;i<n;i++){
max+=num[i];
if(max>=l){
break;
}
}
i==n?printf("impossible\n"):printf("%d\n",i+1);
}
return 0;
}


如果文章有什么错误或者有什么建议,欢迎提出,大家共同交流,一起进步

文章转载请注明出处,请尊重知识产权
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: