您的位置:首页 > 其它

hdu 2425 Hiking Trip

2014-03-08 10:41 369 查看


Hiking Trip

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1245 Accepted Submission(s): 546



Problem Description

Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired and so needs to find the
path that will bring him to the destination with the least amount of time. Can you help him?

You've obtained the area Green's in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or
path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.

Given Green's current position and his destination, please determine the best path for him.

Input

There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, VP, VS, VT (1
<= VP <= 100, 1 <= VS <= 100, 1 <= VT <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines contains exactly
C characters, each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, SR, SC, TR, TC, (0 <= SR <
R, 0 <= SC < C, 0 <= TR < R, 0 <= TC < C), representing your current position and your destination. It is guaranteed that Green's current position is reachable – that is to say, it won't be a '@' square.

There is a blank line after each test case. Input ends with End-of-File.

Output

For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.

Sample Input

4 6
1 2 10
T...TT
TTT###
TT.@#T
..###@
0 1 3 0

4 6
1 2 2
T...TT
TTT###
TT.@#T
..###@
0 1 3 0

2 2
5 1 3
T@
@.
0 0 1 1


Sample Output

Case 1: 14
Case 2: 8
Case 3: -1


#include"stdio.h"
#include"string.h"
#include"stdlib.h"
#include"queue"
#include"iostream"
using namespace std;
#define N 25
int n,m,mark

,t1,t2,t3,ei,ej;
char map

;
int dir[4][2]={0,1,0,-1,-1,0,1,0};
struct node
{
int x,y,t;
friend bool operator<(node a,node b)
{
return a.t>b.t;        //时间小的先出队
}
};
int judge(int x,int y)
{
if(x>=0&&x<n&&y>=0&&y<m&&map[x][y]!='@')
return 1;
return 0;
}
int bfs(int x,int y)
{
priority_queue<node>q;
node cur,next;
int i,di,dj;
cur.x=x;
cur.y=y;
cur.t=0;
q.push(cur);
mark[x][y]=1;
while(!q.empty())
{
cur=q.top();
q.pop();                //删除队首元素
if(cur.x==ei&&cur.y==ej)           //到达目标地点
return cur.t;
for(i=0;i<4;i++)
{
di=cur.x+dir[i][0];            //从当前位置往前走
dj=cur.y+dir[i][1];
if(!mark[di][dj]&&judge(di,dj))
{
mark[di][dj]=1;
next.x=di;
next.y=dj;
if(map[di][dj]=='#')
next.t=cur.t+t1;
else if(map[di][dj]=='.')
next.t=cur.t+t2;
else
next.t=cur.t+t3;
q.push(next);            //入队
}
}
}
return -1;           //无法到达
}
int main()
{
int i,si,sj,cnt=1;
while(scanf("%d%d",&n,&m)!=-1)
{
scanf("%d%d%d",&t1,&t2,&t3);
for(i=0;i<n;i++)
scanf("%s",map[i]);
scanf("%d%d%d%d",&si,&sj,&ei,&ej);
memset(mark,0,sizeof(mark));
printf("Case %d: %d\n",cnt++,bfs(si,sj));

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: