您的位置:首页 > 编程语言 > C语言/C++

【C++】PAT(advanced level)1055. The World's Richest (25)*

2014-03-07 20:28 337 查看

1055. The World's Richest (25)

时间限制
200 ms

内存限制
128000 kB

代码长度限制
16000 B

判题程序
Standard

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths
of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of
no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number
of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It
is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None


aaaaa

1.case 2 case 3超时

#include<iostream>
#include<string>
#include<string>
#include<algorithm>
#include<vector>
#include<climits>

using namespace std;

struct rich{
char name[8];
int age;
int net_worth;
};

bool cmp(rich aa,rich bb){
if(aa.net_worth==bb.net_worth){
if(aa.age==bb.age){
if(aa.name<bb.name ){
return true;
}else {
return false;
}
}else if(aa.age<bb.age){
return true;
}else{
return false;
}
}else if(aa.net_worth>bb.net_worth){
return true;
}else
return false;
}

int main(){
int N,K,n;
vector <rich> a;
vector <rich>::iterator it;
//freopen("in.txt","r",stdin);
while(cin>>N>>K){
n=N;
while(n--){
rich demo;
cin>>demo.name;//>>demo.age>>demo.net_worth;
//	scanf("%s %d %d",&demo.name,&demo.age,&demo.net_worth);
scanf("%d %d",&demo.age,&demo.net_worth);
a.push_back(demo);
}
sort(a.begin(),a.end(),cmp);
n=K;
while(n--){
int num,maxA,minA,count=0;
cin>>num>>minA>>maxA;
cout<<"Case #"<<K-n<<":";
for(it=a.begin();it!=a.end();it++){
if((*it).age<=maxA&&(*it).age>=minA){
count++;
cout<<endl<<(*it).name<<" ";//<<(*it).age<<" "<<(*it).net_worth;
printf("%d %d",(*it).age,(*it).net_worth);
}
if(count==num){
break;
}
}
if(count==0){
cout<<endl<<"None"<<endl;
}else{
cout<<endl;
}
}
}
//fclose(stdin);
system("pause");
return 0;
}


1、同学的版本
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#define N 100005
using namespace std;
typedef struct P
{
int age,worth;
char name[10];
friend bool operator <(const P &A,const P &B)
{
if(A.worth>B.worth||A.worth==B.worth&&A.age<B.age||A.worth==B.worth&&A.age==B.age&&strcmp(A.name,B.name)<0)
return true;
return false;
}
}P;
vector<P>p[201];
int main()
{
int i,j,n,m,size,cur[201],nn,a,b,cc,T;
P t;
while(cin>>n>>m)
{
for(i=1;i<=200;i++)
p[i].clear();
for(i=0;i<n;i++)
{
//cin>>t.name>>t.age>>t.worth;
scanf("%s%d%d",t.name,&t.age,&t.worth);
p[t.age].push_back(t);
}
for(i=1;i<=200;i++)
sort(p[i].begin(),p[i].end());
for(i=0;i<m;i++)
{
cin>>nn>>a>>b;
printf("Case #%d:\n",i+1);
T=nn;
memset(cur,0,sizeof(cur));
while(T--)
{
t.worth=-100000000,cc=-1;
for(j=a;j<=b;j++)
{
size=p[j].size();
if(cur[j]<size)
{
if(p[j][cur[j]]<t)
{
cc=j;
t=p[j][cur[j]];
}
}
}
if(cc==-1)
break;
else
{
printf("%s %d %d\n",t.name,t.age,t.worth);
cur[cc]++;
}
}
}
if(T==nn-1&&cc==-1)
puts("None");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: