您的位置:首页 > 编程语言 > C语言/C++

【C++】PAT(advanced level)1029. Median (25)

2014-03-11 22:09 381 查看

1029. Median (25)

时间限制
400 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the
median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed
that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17

Sample Output
13


1.有一个测试点没有通过!!!

2.算法有一种问题出在,第二行只有一个数字的时候,不能遍历完全。

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<map>
#include<iomanip>
using namespace std;

int main(){
freopen("in.txt","r",stdin);
int N1,N2;
cin>>N1;
int n=N1;
vector<long int> aa;
//vector<int> bb;
while(n--){
long int tt;
scanf("%ld",&tt);
aa.push_back(tt);
}
cin>>N2;
n=N2;
int mid=(N1+N2+1)/2;
int i=0,j=0,fm=-1;
while(n--){
long int tt;
scanf("%ld",&tt);
while(aa[i]<tt&&i<N1&&fm==-1){
j++;
if(j==mid){
fm=aa[i];
}
i++;
}
j++;
if(j==mid){
fm=tt;
}
}
if(fm==-1){
fm=aa[mid-j+i-1];
}
cout<<fm;
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: