您的位置:首页 > 其它

1055. The World's Richest (25)

2014-02-09 22:26 316 查看
Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net
worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the
number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106])
of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names.
It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None


解题思路:本来想用年龄作为数组下标 应该能AC 但是最后还是22分,有个3分超时

23分代码:

#include <iostream>
#include <algorithm>
#include <fstream>
#include <vector>
#include <stdio.h>
#include <string.h>
using namespace std;
struct Node{
char name[10];
int age;
int value;
};
int compare2(Node a,Node b){
if(a.value!=b.value){
return a.value>b.value;
}else{
if(a.age!=b.age){
return a.age<b.age;
}else{
return strcmp(a.name,b.name)<0;
}
}
}
int N,K;
int main()
{
scanf("%d%d",&N,&K);
vector<vector<Node> > arr(201);
for(int i=0;i<N;i++){
Node node;
int index;
scanf("%s%d%d",node.name,&index,&node.value);
arr[index].push_back(node);
}
for(int i=0;i<K;i++){
int num,minAge,maxAge;
scanf("%d%d%d",&num,&minAge,&maxAge);
vector<Node> v;
for(int j=minAge;j<=maxAge;j++){
for(int k=0;k<arr[j].size();k++){
arr[j][k].age = j;
v.push_back(arr[j][k]);
}
}
sort(v.begin(),v.end(),compare2);
printf("Case #%d:\n",i+1);
int output = num<v.size()?num:v.size();
for(int j=0;j<output;j++){
printf("%s %d %d\n",v[j].name,v[j].age,v[j].value);
}
if(output==0){
printf("None\n");
}
}
return 0;
}


AC代码:

#include<iostream>
#include<string>
#include<functional>
#include<algorithm>
#include<vector>
#include<cstdio>
using namespace std;

typedef struct people
{
string Name;
int Age;
int Net_Worth;
bool operator > (const people & p)const
{
if(Net_Worth != p.Net_Worth)
{
return Net_Worth > p.Net_Worth;
}
else
{
if(Age != p.Age) return Age < p.Age;
else
return Name < p.Name;
}
}
}people;

int main()
{
int N; //the total number of people
int K; //the number of queries
int M;//the maximum number of outputs
int Amin,Amax;
int i,j,t1,t2,num;
cin>>N>>K;

vector<people> v(N);
for(i=0; i<N; i++)
{
cin>>v[i].Name;
scanf("%d%d",&v[i].Age,&v[i].Net_Worth);
}

sort(v.begin(),v.end(),greater<people>());
int filter[100000];
int filter_num = 0;
int age_count[201] = {0}; //记录某个年龄出现的次数
for(i=0; i<v.size(); i++)
{
if(++age_count[ v[i].Age ] < 101)
filter[ filter_num++ ] = i;
}

for(i=1; i<=K; i++)
{
scanf("%d%d%d",&M,&Amin,&Amax);
bool first = true;
cout<<"Case #"<<i<<":"<<endl;
int age;
num = 0;
for(j=0; j<filter_num && num<M; j++)
{
age = v[ filter[j] ].Age;
if(age >= Amin && age <= Amax)
{
num++;
//用cout输出会有两组数据超时
//cout<<v[ filter[j] ].Name<<" "<<v[ filter[j] ].Age<<" "<<v[ filter[j] ].Net_Worth<<endl;
cout<<v[ filter[j] ].Name<<" ";
printf("%d %d\n",v[filter[j]].Age,v[filter[j]].Net_Worth);
}
}
if(num == 0)
cout<<"None"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: