您的位置:首页 > 其它

浙大PAT 1064. Complete Binary Search Tree

2014-03-07 18:26 465 查看


1064. Complete Binary Search Tree (30)

时间限制

100 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0

Sample Output:
6 3 8 1 5 7 9 0 2 4


这个题目要求构造完全二叉排序树,如果直接采用普通的建树方式,其实挺麻烦的,我刚开始也是那样做得到,还调试了很久,AC了,但今天突然在网上看到别人做的这个题思路非常的好,所以消化吸收后写了下,其实就是利用了数据结构中完全二叉树的的一个性质:孩子节点的下标为i则其左孩子节点的下标为2*i,右孩子节点的下标为2*i+1,这个性质只有完全二叉树才满足,其实反过来按这个性质构造出来的树就是一个完全二叉树。 要实现这棵完全二叉树也是排序树,其实就简单了,显然一棵二叉排序树的中序遍历序列是递增有序的,所以这就简单了,只要在构造完全二叉树的时候按中序构造就可以了(前提是元素递增有序)。

以前做树的题目都是链接型的,而这个题目用完全二叉树的这个性质确非常的合适,所以记录下,供以后回顾学习。

#include <cstdio>
#include <cstdlib>

const int maxx = 1005;
int node[maxx];
int tree[maxx];
int pos,n;

int cmp(const void *a,const void *b){
	int *pa = (int *)a;
	int *pb = (int *)b;
	return *pa-*pb;
}

void build(int root){
	if(root>n)return;
	int lson = root<<1,rson = (root<<1)+1;
	build(lson);
	tree[root] = node[pos++];
	build(rson);
}

void print(int *a,int n){
	int i;
	for(i=0;i<n;++i){
		printf("%d ",a[i]);
	}
	printf("\n");
}

int main()
{
	int i;
	scanf("%d",&n);
	for(i=0;i<n;++i){
		scanf("%d",&node[i]);
	}

	qsort(node,n,sizeof(int),cmp);

//	print(node,n);

	pos = 0;
	build(1);

	printf("%d",tree[1]);
	for(i=2;i<=n;++i){
		printf(" %d",tree[i]);
	}
	printf("\n");
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: