您的位置:首页 > 编程语言 > C语言/C++

PAT甲级 1064. Complete Binary Search Tree (30)

2017-11-22 14:11 513 查看
题目:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0

Sample Output:
6 3 8 1 5 7 9 0 2 4

思路:
根据完全二叉树的特点,利用中序遍历来写。

我自己只想到了用排序然后建立二叉树,网上则是利用中序遍历:起点为0,当前节点编号为i,则左节点,2*i+1,右节点为2*i+2。

代码:

#include<iostream>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;

int N,num=0;
vector<int> tree(N);
vector<int> key(N);
void inorder(int r)
{
if (r >= N)
return;
else
{
inorder(2*r+1);
tree[r] = key[num++];
cout << r << " " << tree[r] << endl;
inorder(2*r+2);
}
}

int main()
{
ifstream cin;
cin.open("case1.txt");

cin >> N;
key.resize(N);
tree.resize(N);
int i;
for (i = 0; i < N; ++i)
{
cin >> key[i];
}
//排序
sort(key.begin(),key.end());

inorder(0);

cout << tree[0];
for (i = 1; i < N; ++i)
{
cout << " " << tree[i];
}
cout << endl;

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT c++ 完全二叉树