您的位置:首页 > 其它

PAT 1058. A+B in Hogwarts (20)

2014-02-28 01:13 316 查看


1058. A+B in Hogwarts (20)

时间限制

50 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to
compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27

Sample Output:
14.1.28


提交代码

/*
输入格式控制 scanf("%d%*c%d%*c%d %d%*c%d%*c%d", );其中 %*c 用来跳过 任意某个 字符。
*/
#include<stdio.h>
#include<string.h>
const int MAX=10000;
int a[3],b[3],c[3];
void add(int a[],int b[])
{
c[0]=(a[0]+b[0])%29;
c[1]=(a[1]+b[1]+(a[0]+b[0])/29)%17;
c[2]=a[2]+b[2]+(a[1]+b[1]+(a[0]+b[0])/29)/17;
}

int main()
{
//freopen("G:\\in.txt","r",stdin);
//freopen("G:\\our.txt","w",stdout);
while(scanf("%d%*c%d%*c%d %d%*c%d%*c%d",&a[2],&a[1],&a[0],&b[2],&b[1],&b[0])!=EOF){
add(a,b);
printf("%d.%d.%d\n",c[2],c[1],c[0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: