您的位置:首页 > 大数据 > 人工智能

杭电doing homework again

2014-02-19 19:42 309 查看
Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3

3

3 3 3

10 5 1

3

1 3 1

6 2 3

7

1 4 6 4 2 4 3

3 2 1 7 6 5 4

Sample Output

0

3

5

此题贪心,由于时间限制,第一天只能交第一天的,如若我们按照正序来想可能此题并不好做。我们可以先安排后几天交的作业,这样就可以吧性价比最高的找出来,从而得到最优解;

多说无益,程序如下

#include<stdio.h>

#include<string.h>

#include<algorithm>

using namespace std;

int flag[1008]

struct ou{

int time;

int score;

}data[1008]

int cmp(ou a,ou b)

{

if(a.time==b.time)return a.score>b.score;

return a.time<b.time;

}

int main()

{

int t,n,i,j,a[10],;

scanf("%d",&t);

while(t--)

{

memset(flag,-1,sizeof(flag));

scanf("%d",&n);

for(i=0;i<n;i++)

scanf("%d",&data[i].time);

for(i=0;i<n;i++)

scanf("%d",&data[i].score);

int day=1;

for(i=0;i<n;i++)

{

if(day>data[i].time)

{

int min__day=data[i].time;

int min_score=data[i].score;

int min=i;

for(j=0;j<i;j++)

{

if(flag[j]!=-1&&min__day>=data[j].time&&min__score>data[j].score)

{

min__score=data[j].score;

min=j;

}

}

flag[i]=flag[min];

flag[min]=-1;

}

else if(day<=data[i].time)

{

flag[i]=day;

day++;

}

}

int ans=0;

for(i=0;i<n;i++)

{

if(flag[i]==-1)

{

ans+=data[i].score;

}

}

printf("%d\n",ans);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: