您的位置:首页 > 其它

POJ 2312 Battle City 优先队列+BFS

2014-02-10 00:06 519 查看
Battle City

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6589 Accepted: 2221
Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you
can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear
(i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick
wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
Sample Input
3 4
YBEB
EERE
SSTE
0 0

Sample Output
8

题意:给 co*ro 的格子,从Y开始到T结束需要的最短时间。

S,R不可走。进过B要停留一分钟。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
bool vis[305][305];
char pos[305][305];
int co,ro;
struct node{
int x,y,time;
friend bool operator <(node a,node b)
{
return a.time>b.time;
}
};
node st;
bool judge(int x,int y)
{
if(x<0||x>=co||y<0||y>=ro) return 0;
if(vis[x][y]||pos[x][y]=='S'||pos[x][y]=='R')
return 0;
return 1;
}
bool bfs(int a,int b)
{
priority_queue<node>que;
que.push(st);
while(que.size())
{
node cur=que.top();
que.pop();
if(pos[cur.x][cur.y]=='T')
{
printf("%d\n",cur.time);
return 1;
}
for(int i=0;i<4;i++)
{
node pt;
pt.x=cur.x+dir[i][0];
pt.y=cur.y+dir[i][1];
if(!judge(pt.x,pt.y)) continue;
vis[pt.x][pt.y]=1;
pt.time=cur.time+1;
if(pos[pt.x][pt.y]=='B') pt.time++;
que.push(pt);

}
}
printf("-1\n");
}
int main()
{
//freopen("in.txt","r",stdin);
while(~scanf("%d%d",&co,&ro),co+ro)
{
for(int i=0;i<co;i++)
scanf("%s",pos[i]);
for(int i=0;i<co;i++)
for(int j=0;j<ro;j++)
if(pos[i][j]=='Y')
{
st.x=i,st.y=j,st.time=0;
break;
}
memset(vis,0,sizeof(vis));
vis[st.x][st.y]=1;
bfs(st.x,st.y);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj bfs 优先队列