您的位置:首页 > 其它

[Catalan] HDU 1134 Game of Connections

2014-02-06 12:27 295 查看
传送门:Game of Connections


Game of Connections

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2785    Accepted Submission(s): 1591


Problem Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, ... , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number
must be connected to exactly one another. And, no two segments are allowed to intersect.

It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

 

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1. You may assume that 1 <= n <= 100.

 

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

 

Sample Input

2
3
-1

 

Sample Output

2
5

 

Source

Asia 2004, Shanghai (Mainland China), Preliminary

 

解题报告:

此题为高精度卡特兰数。

C语言高精度代码:

#include<stdio.h>
int a[101][101]= {0};
int main(){
int i,j,n,k,b[101],len;
a[1][0]=1;
b[1]=len=1;
for(i=2;i<=100;i++){
for(j=0;j<len;j++) //乘法
a[i][j]=(4*i-2)*a[i-1][j];
for(k=j=0;j<len;j++){
a[i][j]+=k;
k=a[i][j]/10;
a[i][j]%=10;
}
while (k){
a[i][len++]=k%10;
k/=10;
}
for(j=len-1,k=0;j>=0;j--){ //除法
a[i][j]+= k*10;
k=a[i][j]%(i+1);
a[i][j]/=(i+1);
}
while(!a[i][len-1])
len--;
b[i]=len;
}
while(scanf("%d",&n)==1){
if(n==-1)
break;
for(i=b
-1;i>=0;i--)
printf("%d",a
[i]);
printf("\n");
}
return 0;
}


Java代码:

import java.io.*;
import java.math.*;
import java.util.*;

public class Main{
public static void main(String []args){
Scanner cin = new Scanner(System.in);
Integer N = 101,i;
BigInteger []cat = new BigInteger
;

cat[0] = cat[1] = BigInteger.valueOf(1);
for(i = 2; i < N; ++i){
cat[i] = cat[i-1].multiply(BigInteger.valueOf(i*4-2)).divide(BigInteger.valueOf(i+1));
}

while(cin.hasNext()){
i = cin.nextInt();
if(i == -1)
break;
System.out.println(cat[i]);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Catalan