您的位置:首页 > 编程语言 > C语言/C++

[POJ 1002] 487-3279 C++解题报告

2014-01-18 13:22 495 查看
487-3279

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 228365Accepted: 39826
Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with
a hyphen between the third and fourth digits (e.g. 888-1200). The
keypad of a phone supplies the mapping of letters to numbers, as
follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be
added and removed as necessary. The standard form of TUT-GLOP is
888-4567, the standard form of 310-GINO is 310-4466, and the standard
form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from
local businesses. As part of the quality control process you want to
check that no two (or more) businesses in the directory have the same
telephone number.

Input

The
input will consist of one case. The first line of the input specifies
the number of telephone numbers in the directory (up to 100,000) as a
positive integer alone on the line. The remaining lines list the
telephone numbers in the directory, with each number alone on a line.
Each telephone number consists of a string composed of decimal digits,
uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the
characters in the string will be digits or letters.

Output

Generate
a line of output for each telephone number that appears more than once
in any form. The line should give the telephone number in standard form,
followed by a space, followed by the number of times the telephone
number appears in the directory. Arrange the output lines by telephone
number in ascending lexicographical order. If there are no duplicates in
the input print the line:

No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3


翻译:

487-3279

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 228365Accepted: 39826
Description

企业喜欢用容易被记住的电话号码。让电话号码容易被记住的一个办法是将它写成一个容易记住的单词或者短语。例如,你需要给滑铁卢大学打电话时,可以拨打 TUT-GLOP。有时,只将电话号码中部分数字拼写成单词。当你晚上回到酒店,可以通过拨打310-GINO来向Gino's订一份pizza。让电话 号码容易被记住的另一个办法是以一种好记的方式对号码的数字进行分组。通过拨打必胜客的“三个十”号码3-10-10-10,你可以从他们那里订 pizza。

电话号码的标准格式是七位十进制数,并在第三、第四位数字之间有一个连接符。电话拨号盘提供了从字母到数字的映射,映射关系如下:

A, B, 和C 映射到 2

D, E, 和F 映射到 3

G, H, 和I 映射到 4

J, K, 和L 映射到 5

M, N, 和O 映射到 6

P, R, 和S 映射到 7

T, U, 和V 映射到 8

W, X, 和Y 映射到 9

Q和Z没有映射到任何数字,连字符不需要拨号,可以任意添加和删除。 TUT-GLOP的标准格式是888-4567,310-GINO的标准格式是310-4466,3-10-10-10的标准格式是310-1010。

如果两个号码有相同的标准格式,那么他们就是等同的(相同的拨号)

你的公司正在为本地的公司编写一个电话号码薄。作为质量控制的一部分,你想要检查是否有两个和多个公司拥有相同的电话号码。

Input

输入的格式是,第一行是一个正整数,指定电话号码薄中号码的数量(最多100000)。余下的每行是一个电话号码。每个电话号码由数字,大写字母(除了Q和Z)以及连接符组成。每个电话号码中只会刚好有7个数字或者字母。
Output

对于每个出现重复的号码产生一行输出,输出是号码的标准格式紧跟一个空格然后是它的重复次数。如果存在多个重复的号码,则按照号码的字典升序输出。如果输入数据中没有重复的号码,输出一行:

No duplicates.

解决思路

这是一道简单的模拟题,第一,要记得处理无重复号码的情况,第二,要记得处理只有两个号码,且两个号码相同的情况,不注意边界的话,很容易弄错。

源码

C++解题

/*
poj 1002
version:1.0
author:Knight
Email:S.Knight.Work@gmail.com         www.getyourwant.com
*/

#include<cstdio>

#include<cstring>

#include<cstdlib>

using namespace std;

char Stand[100010][10];

//建立26个字母对应的数字键,如A-2,B-2,D-3此时Map【0】=2,Map【1】=2,Map【3】=3.即Map的下标为字母在字母表中的序列号,从0开始

int Map[]= {2,2,2,3,3,3, 4,4,4, 5,5,5, 6,6,6, 7,-1,7,7, 8,8,8, 9,9,9,-1};

//将PhoneNO转换成标准号码

void TransToStand(char* PhoneNO,char* StandNO);

//用于qsort字符串排序的比较函数

int StrCmp(const void *a, const void *b);

int main(void)

{

//printf("%d", sizeof(Map)/sizeof(int));

int T;

int i;

char Tmp[50];

scanf("%d", &T);

getchar();

for (i=0; i<T; i++)

{

gets(Tmp);

TransToStand(Tmp, Stand[i]);

}

qsort(Stand, T, sizeof(Stand[0]), StrCmp);

int Cnt = 1;//当前相同标准号码的数量

bool IsDuplicate = false;

strcpy(Stand[T], "");

for (i=0; i<T; i++)

{

if (strcmp(Stand[i], Stand[i+1]) == 0)

{

Cnt++;

}

else

{

if (Cnt > 1)

{

printf("%s %d\n", Stand[i], Cnt);

IsDuplicate = true;

}

Cnt = 1;

}

}

if (!IsDuplicate)

{

printf("No duplicates.\n");

}

return 0;

}

//将PhoneNO转换成标准号码

void TransToStand(char* PhoneNO,char* StandNO)

{

int i,j=0;

int Len = strlen(PhoneNO);

StandNO[3] = '-';

StandNO[8] = '\0';

for (i=0; i<Len; i++)

{

if (PhoneNO[i] >= '0' && PhoneNO[i] <= '9')//是数字则直接转换

{

StandNO[j] = PhoneNO[i];

j++;

if (3 == j)

{

j++;

}

else if (8 == j)

{

return ;

}

}

else if (PhoneNO[i] >= 'A' && PhoneNO[i] <= 'Z')

{

StandNO[j] = Map[PhoneNO[i] - 'A'] + '0';

j++;

if (3 == j)

{

j++;

}

else if (8 == j)

{

return ;

}

}

}

}

//用于qsort字符串排序的比较函数

int StrCmp(const void *a, const void *b)

{

return strcmp((char*)a, (char*)b);

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: