您的位置:首页 > 编程语言 > C语言/C++

[POJ 1005] I Think I Need a Houseboat C++解题

2014-01-18 13:32 489 查看
I Think I Need a Houseboat

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 81874Accepted: 35368
Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is
being lost forms a semicircle. This semicircle is part of a circle
centered at (0,0), with the line that bisects the circle being the X
axis. Locations below the X axis are in the water. The semicircle has an
area of 0 at the beginning of year 1. (Semicircle illustrated in the
Figure.)



Input

The
first line of input will be a positive integer indicating how many data
sets will be included (N). Each of the next N lines will contain the X
and Y Cartesian coordinates of the land Fred is considering. These will
be floating point numbers measured in miles. The Y coordinate will be
non-negative. (0,0) will not be given.
Output

For
each data set, a single line of output should appear. This line should
take the form of: “Property N: This property will begin eroding in year
Z.” Where N is the data set (counting from 1), and Z is the first year
(start from 1) this property will be within the semicircle AT THE END OF
YEAR Z. Z must be an integer. After the last data set, this should
print out “END OF OUTPUT.”
Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside.
2.This problem will be judged automatically. Your answer must match
exactly, including the capitalization, punctuation, and white-space.
This includes the periods at the ends of the lines.

3.All locations are given in miles.

解决思路

这是一道很简单的计算几何题,本质就是计算点是否在指定的半圆内。

源码

/*
poj 1000
version:1.0
author:Knight
Email:S.Knight.Work@gmail.com
*/

#include<cstdio>
#include<cmath>
using namespace std;
const double PI = 3.1415926;
int main(void)
{
double S;//被腐蚀陆地的总面积
double r;//腐蚀陆地的半径
int i,j;
int T;
double X,Y;//Fred的坐标
double Distance;//Fred据坐标原点的距离
scanf("%d", &T);
for (i=1; i<=T; i++)
{
scanf("%lf%lf", &X, &Y);
Distance = sqrt(X * X + Y * Y);
S = 0.0;
for (j=1; ; j++)
{
S += 50.0;
r = sqrt(2 * S / PI);
if (r >= Distance)
{
break;
}
}
printf("Property %d: This property will begin eroding in year %d.\n", i, j);
}
printf("END OF OUTPUT.\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: