您的位置:首页 > 编程语言 > C语言/C++

[POJ 1004] Financial Management C++解题

2014-01-18 13:29 357 查看
Financial Management

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 116320Accepted: 53669
Description

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

翻译:

我就不一句一句翻译了,题目的大意就是Larry想要计算她一年12个月的余额平均值。

然后,是12行,分别输入一年12个月的余额,输出它们的平均值,前面带“$”符合。

解决思路

这也是一道练习C语言语法的水题,

源码

/*
poj 1000
version:1.0
author:Knight
Email:S.Knight.Work@gmail.com
*/

#include<cstdio>
using namespace std;
int main(void)
{
int i;
double Tmp, Sum;
Sum = 0.0;
for (i=0; i<12; i++)
{
scanf("%lf", &Tmp);
Sum += Tmp;
}
printf("$%.2lf\n", Sum / 12);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: