您的位置:首页 > 其它

最大公约数和最小公倍数

2013-11-17 21:34 183 查看

Sixth Grade Math

Time Limit: 1000MS Memory Limit: 65535KB
Submissions: 162 Accepted: 120
Description
In sixth grade, students are presented with different ways to calculate the Least Common Multiple (LCM) and the Greatest Common Factor (GCF) of two integers. The LCM of two integers a and b is the smallest positive integer that is a multiple of both a and b. The GCF of two non-zero integers a and b is the largest positive integer that divides both a and b without remainder.For this problem you will write a program that determines both the LCM and GCF for positive integers.Input
The first line of input contains a single integer N, (1 < = N < = 1000) which is the number of data sets that follow. Each data set consists of a single line of input containing two positive integers, a and b, (1< = a,b < = 1000) separated by a space.Output
For each data set, you should generate one line of output with the following values: The data set number as a decimal integer (start counting at one), a space, the LCM, a space, and the GCF.

Sample Input

3
5 10
7 23
42 56

Sample Output

1 10 5
2 161 1
3 168 14

#include<stdio.h>
int main()
{
int n,i;
int a[1000],b[1000];
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d%d",&a[i],&b[i]);
}
for(i=1;i<=n;i++)
{
int da,xiao,yu;
if(a<b)
{
int t=a[i];
a[i]=b[i];
b[i]=t;
}
da=a[i];
xiao=b[i];
while(b[i])
{
yu=a[i]%b[i];
a[i]=b[i];
b[i]=yu;
}
printf("%d %d %d\n",i,da*xiao/a[i],a[i]);
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: