您的位置:首页 > 移动开发 > IOS开发

uva-11111 Generalized Matrioshkas

2013-07-04 15:44 302 查看
Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll
inside. Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.
Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in
two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.
Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented
by m we find the toys represented by n1, n2, ..., nr, it
must be true that n1 + n2 + ... + nr < m. And if this is the case, we say that toy m contains directly the
toys n1, n2, ..., nr . It should be clear that toys that may be contained in any of the toys n1, n2, ..., nr are
not considered as directly contained in the toy m.
A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:

a1 a2 ... aN
such that toy k is represented in the sequence with two integers - k and k, with the negative one occurring in the sequence first that the positive one.
For example, the sequence

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
represents a generalized matrioshka conformed by six toys, namely, 1, 2 (twice), 3, 7 and 9. Note that toy 7 contains
directly toys 2 and 3. Note that the first copy of toy 2 occurs left from the second one and that the second copy contains directly a toy 1. It would be
wrong to understand that the first -2 and the last 2 should be paired.
On the other hand, the following sequences do not describe generalized matrioshkas:

-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
because toy 2 is bigger than toy 1 and cannot be allocated inside it.

-9 -7 -2 2 -3 -2 -1 1 2 3 7 -2 2 9
because 7 and 2 may not be allocated together inside 9.

-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
because there is a nesting problem within toy 3.

Your problem is to write a program to help Vladimir telling good designs from bad ones.

Input

The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than 107.

Output

Output texts for each input case are presented in the same order that input is read.
For each test case the answer must be a line of the form

:-) Matrioshka!

if the design describes a generalized matrioshka. In other case, the answer should be of the form

:-( Try again.

Sample Input

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
-100 -50 -6 6 50 100
-100 -50 -6 6 45 100
-10 -5 -2 2 5 -4 -3 3 4 10
-9 -5 -2 2 5 -4 -3 3 4 9


Sample Output

:-) Matrioshka!
:-( Try again.
:-( Try again.
:-) Matrioshka!
:-( Try again.
:-) Matrioshka!
:-( Try again.

这个题 的意思是给出一些数,判断是否满足括号平衡和包涵的关系,
包涵关系:
9 -2 2,-7 7 9(不符合要求,9直接包涵2和7,但9不大于2+7)
9 -1 1 - 2 2 9(符合要求,因为9>1+2)
#include <iostream>
#include<deque>
#include<algorithm>
#include<cstdio>
#include<stack>
#include<string>
#include<vector>
#include<map>
#include<sstream>
using namespace std;
struct node
{
    int v,sum;
    node(int a,int b):v(a),sum(b){}
};
bool check(vector<int>& v)
{
    stack<node>st;
    for(int i=0;i<v.size();i++)
    {
        if(v[i]<0)
            st.push(node(v[i],v[i]));
        else
        {
            if(!st.empty()&&st.top().v+v[i]==0)
            {
                st.pop();
                if(!st.empty())
                {
                    node top=st.top();st.pop();
                    top.sum+=v[i];
                    if(top.sum>=0)return false;
                        st.push(top);
                }
            }
            else return false;
        }
    }
    return st.empty();
}
int main()
{
    string line;
    while(getline(cin,line))
    {
        vector<int>v;
        int num;
        istringstream in(line);
        while(in>>num)v.push_back(num);
        if(check(v))
            cout<<":-) Matrioshka!"<<endl;
        else cout<<":-( Try again."<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: