您的位置:首页 > 大数据 > 人工智能

TOJ 2909 ZOJ 3175 Number of Containers / 数论

2013-11-14 16:11 295 查看

Number of Containers

时间限制(普通/Java):1000MS/3000MS 运行内存限制:65536KByte



For two integers m and k, k is said to be a container of
m if k is divisible by m. Given 2 positive integers
n and m (m < n), the function f(n, m) is defined to be the number of containers of
m which are also no greater than n. For example, f(5, 1)=4, f(8, 2)=3, f(7, 3)=1, f(5, 4)=0...

Let us define another function F(n) by the following equation:



Now given a positive integer n, you are supposed to calculate the value of F(n).

输入

There are multiple test cases. The first line of input contains an integer
T(T<=200) indicating the number of test cases. Then T test cases follow.

Each test case contains a positive integer n (0 <
n <= 2000000000) in a single line.

输出

For each test case, output the result F(n) in a single line.

样例输入

2
1
4


样例输出

0
4


/article/2411221.html

#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
int main()
{
	int ncases,i,n;
	__int64 ans;
	scanf("%d",&ncases);
	while( ncases-- )
	{
		ans = 0;
		scanf("%d",&n);
		for(i=1; i<=sqrt(n); i++)
			ans += (n/i);
		ans *= 2;
		i--;
		ans = ans - i*i - n;
		printf("%I64d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: