您的位置:首页 > 大数据 > 人工智能

hdu_1039_Easier Done Than Said_201311051511

2013-11-05 15:53 357 查看

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6333 Accepted Submission(s): 3145

[align=left]Problem Description[/align]
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.
FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:
It must contain at least one vowel.
It cannot contain three consecutive vowels or three consecutive consonants.
It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.
(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

[align=left]Input[/align]
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

[align=left]Output[/align]
For each password, output whether or not it is acceptable, using the precise format shown in the example.

[align=left]Sample Input[/align]

a

tv

ptoui

bontres

zoggax

wiinq

eep

houctuh

end

[align=left]Sample Output[/align]

<a> is acceptable.

<tv> is not acceptable.

<ptoui> is not acceptable.

<bontres> is not acceptable.

<zoggax> is not acceptable.

<wiinq> is not acceptable.

<eep> is acceptable.

<houctuh> is acceptable.

#include <stdio.h>
#include <string.h>

char str[22];

int f(char c)
{
if(c=='a')
return 1;
else if(c=='e')
return 1;
else if(c=='i')
return 1;
else if(c=='o')
return 1;
else if(c=='u')
return 1;
else
return 0;
}

int consecutive(char a,char b,char c)
{
int t;
t=f(a)+f(b)+f(c);
if(t==3||t==0)
return 1;
else
return 0;
}
int main()
{
memset(str,0,sizeof(str));
while(scanf("%s",str),strcmp(str,"end")!=0)
{
int i,j,k=0,t1=0,t2=0;
int len;
printf("<%s> ",str);
len = strlen(str);
for(i=0;i<len;i++)
{
if(str[i]=='a')
k++;
else if(str[i]=='e')
k++;
else if(str[i]=='i')
k++;
else if(str[i]=='o')
k++;
else if(str[i]=='u')
k++;
if(i+2<len)
{
if(consecutive(str[i],str[i+1],str[i+2]))
{
printf("is not acceptable.\n");
break;
}
}
if(str[i+1]==str[i])
{
if(str[i]=='e'||str[i]=='o')
i++;
else
{
printf("is not acceptable.\n");
break;
}
}
}
if(k==0&&i>=len)
printf("is not acceptable.\n");
if(k>0&&i>=len)
printf("is acceptable.\n");
}
return 0;
}


没有想象中的那么难,其实是一道简单题
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: