您的位置:首页 > 其它

PAT:1001. A+B Format (20)

2013-10-23 16:51 351 查看



1001. A+B Format (20)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9

Sample Output
-999,991


#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>

int main()
{
int a,b,c,count,string_len,residue;
char *point,ch[12];

point = ch;
scanf("%d%d",&a,&b);

// -1000000 <= a, b <= 1000000
if(abs(a)>1000000 || abs(b)>1000000)
return -1;

c = a + b;
sprintf(ch,"%d",c);
string_len = strlen(ch);

if(c>0)
residue = string_len%3;
else
residue = (string_len-1)%3+1;

if(residue == 1)
{
printf("%c",*point++);
}
if(residue > 1)
{
for(count =1;count<=residue;count++)
{
printf("%c",*point++);
}
printf(",");
}

for(count = 1; count < (string_len-residue);count++)
{
printf("%c",*point++);
if(!(count%3))
printf(",");
}
printf("%c",*point);

return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: