您的位置:首页 > 其它

浙江大学PAT上机题解析之1001. A+B Format (20)

2013-08-11 14:43 316 查看

1001. A+B Format (20)

时间限制 
400 ms

内存限制 
32000 kB

代码长度限制 
16000 B

判题程序   
Standard

作者   
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case.  Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000.  The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line.  The sum must be written in the standard format.

Sample Input
-1000000 9

Sample Output
-999,991

#include<iostream>
#include <string>
#include <algorithm>

using namespace std;

int main()
{

int M,N,sum=0;
string  str;
int flag=0;
string::iterator it;
cin>>M>>N;
sum = M+N;
if (sum<0)
{
sum  = 0-sum;
flag=1;
}

while(sum)
{
char  ch = '0'+sum%10;

str.push_back(ch);

sum/=10;

}
if (str.empty())
cout<<"0"<<endl;
if (flag)
cout<<"-";
reverse(str.begin(),str.end());
if (!str.empty()&&str.size()<=3)
{
cout<<str;
}
else
{
int num = str.size()%3;

if (num==1)
{
cout<<*str.begin()<<",";
}
else
if (num==2)
{
cout<<*str.begin()<<*(str.begin()+1)<<",";
}
int k=1;

for (it=str.begin()+num;it!=str.end();it++)
{
if (k==4)
{
cout<<",";
k=1;
}
cout<<*it;
k++;
}

}

cout<<endl;

//  system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: