您的位置:首页 > 产品设计 > UI/UE

UVa 133 The Dole Queue (模拟循环链表)

2013-10-22 09:55 429 查看


133 - The Dole Queue

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=103&page=show_problem&problem=69

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing
inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts
from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person
and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers
will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0


Sample output


4

8,

9

5,

3

1,

2

6,

10,

7
where

represents a space.

完整代码:

/*0.015s*/

#include<cstdio>
#include<cstring>

int people[20];
bool vis[20];

int main()
{
	int n, k, m, i, left, count, flag1, flag2;
	for (i = 1; i < 20; ++i)
		people[i] = i;
	while (scanf("%d%d%d", &n, &k, &m), n)
	{
		memset(vis, 0, sizeof(vis));
		left = n;
		flag1 = 0, flag2 = n - 1;
		while (left)
		{
			for (count = 1;; flag1 = (flag1 + 1) % n)
			{
				if (!vis[flag1])
				{
					if (count < k) ++count;
					else
					{
						printf("%3d", flag1 + 1);///我被题意误导了,PE了一次...
						--left;
						break;
					}
				}
			}
			for (count = 1;; flag2 = (flag2 - 1 + n) % n)
			{
				if (!vis[flag2])
				{
					if (count < m) ++count;
					else
					{
						if (flag2 != flag1) printf("%3d", flag2 + 1), --left;
						vis[flag1] = vis[flag2] = true;
						break;
					}
				}
			}
			if (left) putchar(',');
		}
		putchar(10);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: