您的位置:首页 > 编程语言 > Go语言

UVa 686 Goldbach's Conjecture (II) (哥德巴赫猜想)

2013-10-05 11:55 381 查看


686 - Goldbach's Conjecture (II)

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=627

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of
all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2)
and (p2, p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215.
The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

6
10
12
0


Sample Output

1
2
1


这一题

完整代码:

/*0.015s*/

#include<cstdio>
#include<cmath>
const int maxn = 1 << 15;
const int m = (int)sqrt(maxn);

bool vis[maxn];

inline void cal_prime()
{
	int i, j;
	for (i = 2; i <= m; ++i)
		if (!vis[i])
			for (j = i * i; j < maxn; j += i)
				vis[j] = true;
}

int main()
{
	cal_prime();
	int n, m, i, count;
	while (scanf("%d", &n), n)
	{
		count = 0, m = n >> 1;
		for (i = 2; i <= m; ++i)
			if (!vis[i] && !vis[n - i])
				++count;
		printf("%d\n", count);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: