您的位置:首页 > 其它

UVa 443 / POJ 2247 Humble Numbers (4因子-丑数&STL灵活运用)

2013-10-06 10:39 399 查看


443 - Humble Numbers

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=384

http://poj.org/problem?id=2247

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence.

Input Specification

The input consists of one or more test cases. Each test case consists of one integer n with

.
Input is terminated by a value of zero (0) for n.

Output Specification

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th"
for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0


Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.


用set秒杀。

类似的题:

POJ 1338 Ugly Numbers

POJ 2545 Hamming Problem

完整代码:

/*0.018s*/

#include<cstdio>
#include<cstring>
#include<set>
#include<vector>
using namespace std;
typedef long long ll;

set<ll> s;
set<ll>::iterator it;
char str[5];

int main()
{
	s.insert(1);
	it = s.begin();
	///要满足第5842个数为2000000000,s.size()要达到这么多
	///同时为了不爆上限,类型设为long long
	while (s.size() < 7000)
	{
		s.insert(*it * 2);
		s.insert(*it * 3);
		s.insert(*it * 5);
		s.insert(*it * 7);
		++it;
	}
	vector<ll> v(s.begin(), s.end());
	int n;
	while (scanf("%d", &n), n)
	{
		if (n % 10 == 1 && (n % 100) / 10 != 1)
			strcpy(str, "st");
		else if (n % 10 == 2 && (n % 100) / 10 != 1)
			strcpy(str, "nd");
		else if (n % 10 == 3 && (n % 100) / 10 != 1)
			strcpy(str, "rd");
		else
			strcpy(str, "th");
		printf("The %d%s humble number is %lld.\n", n, str, v[n - 1]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: