您的位置:首页 > 其它

UVa 10161 Ant on a Chessboard (简单数学)

2013-09-14 12:43 417 查看


10161 - Ant on a Chessboard

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=99&page=show_problem&problem=1102

Background

One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a
snake.

For example, her first 25 seconds went like this:

( the numbers in the grids stands for the time when she went into the grids)



25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1



1 2 3 4 5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

Input

Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

Output

For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

Sample Input

8

20

25

0

Sample Output

2 3

5 4

1 5

题意:找到数字对应的行和列。

思路:找规律,奇数行,起始为行数的平方。偶数列,起始为列数的平方。行和列有与数字匹配的规律。依次确定所在的行和列。

完整代码:

/*0.012s*/

#include<cstdio>
#include<cmath>

int main(void)
{
	int sqr, n, x, y, corner;
	while (scanf("%d", &n), n)
	{
		sqr = (int)sqrt(n - 1) + 1;
		corner = sqr * sqr - sqr + 1;
		if ((sqr & 1) == 0)
		{
			if (n >= corner)
			{
				x = sqr;
				y = sqr - (n - corner);
			}
			else
			{
				x = sqr - (corner - n);
				y = sqr;
			}
		}
		else
		{
			if (n >= corner)
			{
				x = sqr - (n - corner);
				y = sqr;
			}
			else
			{
				x = sqr;
				y = sqr - (corner - n);
			}
		}
		printf("%d %d\n", x, y);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: