您的位置:首页 > 其它

poj1698 Alice's Chance 最大流

2013-09-07 15:12 197 查看
Alice's Chance

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4472 Accepted: 1884
Description
Alice, a charming girl, have been dreaming of being a movie star for long. Her chances will come now, for several filmmaking companies invite her to play the chief role in their new films. Unfortunately, all these companies will
start making the films at the same time, and the greedy Alice doesn't want to miss any of them!! You are asked to tell her whether she can act in all the films.

As for a film,
it will be made ONLY on some fixed days in a week, i.e., Alice can only work for the film on these days;

Alice should work for it at least for specified number of days;

the film MUST be finished before a prearranged deadline.

For example, assuming a film can be made only on Monday, Wednesday and Saturday; Alice should work for the film at least for 4 days; and it must be finished within 3 weeks. In this case she can work for the film on Monday of the first week, on Monday and Saturday
of the second week, and on Monday of the third week.

Notice that on a single day Alice can work on at most ONE film.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a single line containing an integer N (1 <= N <= 20), the number of films. Each of
the following n lines is in the form of "F1 F2 F3 F4 F5 F6 F7 D W". Fi (1 <= i <= 7) is 1 or 0, representing whether the film can be made on the i-th day in a week (a week starts on Sunday): 1 means that the film can be made on this day, while 0 means the
opposite. Both D (1 <= D <= 50) and W (1 <= W <= 50) are integers, and Alice should go to the film for D days and the film must be finished in W weeks.
Output
For each test case print a single line, 'Yes' if Alice can attend all the films, otherwise 'No'.
Sample Input
2
2
0 1 0 1 0 1 0 9 3
0 1 1 1 0 0 0 6 4
2
0 1 0 1 0 1 0 9 4
0 1 1 1 0 0 0 6 2

Sample Output
Yes
No

Hint

A proper schedule for the first test case:

date     Sun    Mon    Tue    Wed    Thu    Fri    Sat

week1          film1  film2  film1         film1

week2          film1  film2  film1         film1

week3          film1  film2  film1         film1

week4          film2  film2  film2


Source
POJ Monthly--2004.07.18
很好的最大流的题 我们把0看成源点,把371看成终点,1-350天数,看成中间的点,这样,从0到351- 357,连一条是流量为d的边,在天数和终点都连为1的边,最后跑一次,最大流算错 法就可以了 !
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
#define E 20000
#define N 400
#define typec int
const typec inf=0x3f3f3f3f;
int day
[10];
struct edge{int x,y,nxt;typec c;}bf[E];
int ne,head
,cur
,ps
,dep
;
void addedge(int x,int y,typec c)
{
bf[ne].x=x;bf[ne].y=y;bf[ne].c=c;
bf[ne].nxt=head[x];head[x]=ne++;
bf[ne].x=y;bf[ne].y=x;bf[ne].c=0;
bf[ne].nxt=head[y];head[y]=ne++;
}
typec flow(int n,int s,int t)
{
typec  tr,res=0;
int i,j,k,f,r,top;
while(1)
{
memset(dep,-1,n*sizeof(int));
for(f=dep[ps[0]=s]=0,r=1;f!=r;)
{
for(i=ps[f++],j=head[i];j;j=bf[j].nxt)
{
if(bf[j].c&&-1==dep[k=bf[j].y])
{
dep[k]=dep[i]+1;ps[r++]=k;
if(k==t){f=r;break;}
}
}
}
if(-1==dep[t])break;
memcpy(cur,head,n*sizeof(int));
for(i=s,top=0;;)
{
if(i==t)
{
for(k=0,tr=inf;k<top;k++)
{
if(bf[ps[k]].c<tr)
tr=bf[ps[f=k]].c;
}
for(k=0;k<top;++k)
{
bf[ps[k]].c-=tr,bf[ps[k]^1].c+=tr;
}
res+=tr;i=bf[ps[top=f]].x;
}
for(j=cur[i];cur[i];j=cur[i]=bf[cur[i]].nxt)
if(bf[j].c&&dep[i]+1==dep[bf[j].y])break;
if(cur[i])
{
ps[top++]=cur[i];i=bf[cur[i]].y;
}
else
{
if(0==top)break;
dep[i]=-1;i=bf[ps[--top]].x;
}
}
}
return res;
}
int main()
{
int tcase,n,s,i,j;
scanf("%d",&tcase);
while(tcase--)
{
ne=2;
memset(head,0,sizeof(head));
scanf("%d",&n);
s=0;
for(i=1;i<=350;i++)
{
addedge(i,371,1);
}
for(i=1;i<=n;i++)
{
for(j=0;j<9;j++)
{
scanf("%d",&day[i][j]);
}
s+=day[i][7];
addedge(0,350+i,day[i][7]);
for(j=0;j<7;j++)
if(day[i][j])
{
for(int k=1;k<=day[i][8];k++)
addedge(350+i,7*(k-1)+j+1,1);
}
}
if(flow(372,0,371)==s)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: