您的位置:首页 > 移动开发

TOJ 3667 HDU 2830 Matrix Swapping II

2013-08-20 19:00 381 查看

Matrix Swapping II

时间限制(普通/Java):1000MS/3000MS 运行内存限制:65536KByte



描述

Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

输入

There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating
the N * M matrix

输出

Output one line for each test case, indicating the maximum possible goodness.

样例输入

3 4
1011
1001
0001
3 4
1010
1001
0001


样例输出

4
2




自己想不到 是参考别人的

主要是那个排序 排序了 就可以枚举了

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAX 1010

char str[MAX];
int dp[MAX];
int a[MAX];

bool cmp(int x,int y)
{
	return x>y;
}

int main()
{
	int n,m,max,i,j;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		max= -1;
		memset(a,0,sizeof(a));
		for(i = 1; i<= n; i++)
		{
			scanf("%s",str+1);
			for(j = 1;j <= m; j++)
			{
				if(str[j] == '1')
				{
					a[j]++;
				}
				else
				{
					a[j] = 0;
				}
				dp[j] = a[j];
			}
			sort(dp+1,dp+m+1,cmp);
			for(j = 1; j <= m; j++)
			{
				max = max > dp[j] * j ? max : dp[j] * j;
			}
		}
		printf("%d\n",max);
	}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: